Jump to content

Recommended Posts

I had the right side panel give me some issues on my build. Found the Oil pump p/n x17 was interfering. I removed it and tossed it as i was doing a closed cowl build. After that everything was good, until i dropped it (again!!), fit was off after that....

 

 

Don

Share this post


Link to post
Share on other sites

Hi Don, it wasn't X17 as I didn't install any if the engine details. I think I must have induced a slight twist somewhere.

 

Maru, it wasn't too bad. Just more unexpected was all.

 

I finally got to the bench and made a bit more progress. I masked off the wheel wells and sprayed a coat of Gunze Sky .

 

IMG_20160328_223809.jpg

 

IMG_20160328_225245.jpg

 

It might need another coat but I'll check later and see.

 

Carl

Share this post


Link to post
Share on other sites

I had the right side panel give me some issues on my build. Found the Oil pump p/n x17 was interfering. I removed it.......

Don

Yep, that oil pump is a piece too far for me too Don, I'm going to fit it but I've had to "engineer" a way of doing it and it will be slightly out of position.

Max

Share this post


Link to post
Share on other sites

Interesting notes regarding the villainous X17 :ph34r:

I shall endeavour to be on my guard when I reach that stage.

 

Lovely, smooth underside Carl. Good job.

 

Cheers.

The key question Guy is when to try fitting it, I think if you fit it to the pipework and bearers early on, you'll have problems like I did with it fouling the aft end of the engine.

Max

Share this post


Link to post
Share on other sites

Interesting notes regarding the villainous X17 :ph34r:

I shall endeavour to be on my guard when I reach that stage.

 

Lovely, smooth underside Carl. Good job.

 

Cheers.

Thanks Guy!

 

I'm out to a movie tonight so I'll probably have more done tomorrow night.

 

Carl

Share this post


Link to post
Share on other sites

Thanks Shaka and Dennis!

 

I remembered this time to first spray a coat of interior green on the canopy. I forgot to do so on my FR IX build.

 

IMG_20160330_230558.jpg

 

It's not a great shot but I sanded off and then polished the mould parting line off the centre section. So one more step closer.

 

IMG_20160330_223834.jpg

 

Carl

Share this post


Link to post
Share on other sites

Looks good, check that mask on the windscreen/top -- looks like it's peeling off.

Thanks Shaka! The mask was indeed peeling off. The Montex ones really don't like compound curves much. I've replaced it with the over from the kit along with the one for the sliding section.

 

Carl

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×